• Tom Lane's avatar
    Improve test coverage for LISTEN/NOTIFY. · b10f40bf
    Tom Lane authored
    We had no actual end-to-end test of NOTIFY message delivery.  In the
    core async.sql regression test, testing this is problematic because psql
    traditionally prints the PID of the sending backend, making the output
    unstable.  We also have an isolation test script, but it likewise
    failed to prove that delivery worked, because isolationtester.c had
    no provisions for detecting/reporting NOTIFY messages.
    
    Hence, add such provisions to isolationtester.c, and extend
    async-notify.spec to include direct tests of basic NOTIFY functionality.
    
    I also added tests showing that NOTIFY de-duplicates messages normally,
    but not across subtransaction boundaries.  (That's the historical
    behavior since we introduced subtransactions, though perhaps we ought
    to change it.)
    
    Patch by me, with suggestions/review by Andres Freund.
    
    Discussion: https://postgr.es/m/31304.1564246011@sss.pgh.pa.us
    b10f40bf
async-notify.spec 2.84 KB