• Tom Lane's avatar
    Restore the portal-level snapshot after procedure COMMIT/ROLLBACK. · 84f5c290
    Tom Lane authored
    COMMIT/ROLLBACK necessarily destroys all snapshots within the session.
    The original implementation of intra-procedure transactions just
    cavalierly did that, ignoring the fact that this left us executing in
    a rather different environment than normal.  In particular, it turns
    out that handling of toasted datums depends rather critically on there
    being an outer ActiveSnapshot: otherwise, when SPI or the core
    executor pop whatever snapshot they used and return, it's unsafe to
    dereference any toasted datums that may appear in the query result.
    It's possible to demonstrate "no known snapshots" and "missing chunk
    number N for toast value" errors as a result of this oversight.
    
    Historically this outer snapshot has been held by the Portal code,
    and that seems like a good plan to preserve.  So add infrastructure
    to pquery.c to allow re-establishing the Portal-owned snapshot if it's
    not there anymore, and add enough bookkeeping support that we can tell
    whether it is or not.
    
    We can't, however, just re-establish the Portal snapshot as part of
    COMMIT/ROLLBACK.  As in normal transaction start, acquiring the first
    snapshot should wait until after SET and LOCK commands.  Hence, teach
    spi.c about doing this at the right time.  (Note that this patch
    doesn't fix the problem for any PLs that try to run intra-procedure
    transactions without using SPI to execute SQL commands.)
    
    This makes SPI's no_snapshots parameter rather a misnomer, so in HEAD,
    rename that to allow_nonatomic.
    
    replication/logical/worker.c also needs some fixes, because it wasn't
    careful to hold a snapshot open around AFTER trigger execution.
    That code doesn't use a Portal, which I suspect someday we're gonna
    have to fix.  But for now, just rearrange the order of operations.
    This includes back-patching the recent addition of finish_estate()
    to centralize the cleanup logic there.
    
    This also back-patches commit 2ecfeda3 into v13, to improve the
    test coverage for worker.c (it was that test that exposed that
    worker.c's snapshot management is wrong).
    
    Per bug #15990 from Andreas Wicht.  Back-patch to v11 where
    intra-procedure COMMIT was added.
    
    Discussion: https://postgr.es/m/15990-eee2ac466b11293d@postgresql.org
    84f5c290
plpgsql-toast.spec 3.54 KB