• Tom Lane's avatar
    Avoid assertion failure with LISTEN in a serializable transaction. · 6b802cfc
    Tom Lane authored
    If LISTEN is the only action in a serializable-mode transaction,
    and the session was not previously listening, and the notify queue
    is not empty, predicate.c reported an assertion failure.  That
    happened because we'd acquire the transaction's initial snapshot
    during PreCommit_Notify, which was called *after* predicate.c
    expects any such snapshot to have been established.
    
    To fix, just swap the order of the PreCommit_Notify and
    PreCommit_CheckForSerializationFailure calls during CommitTransaction.
    This will imply holding the notify-insertion lock slightly longer,
    but the difference could only be meaningful in serializable mode,
    which is an expensive option anyway.
    
    It appears that this is just an assertion failure, with no
    consequences in non-assert builds.  A snapshot used only to scan
    the notify queue could not have been involved in any serialization
    conflicts, so there would be nothing for
    PreCommit_CheckForSerializationFailure to do except assign it a
    prepareSeqNo and set the SXACT_FLAG_PREPARED flag.  And given no
    conflicts, neither of those omissions affect the behavior of
    ReleasePredicateLocks.  This admittedly once-over-lightly analysis
    is backed up by the lack of field reports of trouble.
    
    Per report from Mark Dilger.  The bug is old, so back-patch to all
    supported branches; but the new test case only goes back to 9.6,
    for lack of adequate isolationtester infrastructure before that.
    
    Discussion: https://postgr.es/m/3ac7f397-4d5f-be8e-f354-440020675694@gmail.com
    Discussion: https://postgr.es/m/13881.1574557302@sss.pgh.pa.us
    6b802cfc
async-notify.spec 3.32 KB