• Alexander Korotkov's avatar
    Reduce length of GIN predicate locking isolation test suite · 0c6f4f92
    Alexander Korotkov authored
    Isolation test suite of GIN predicate locking was criticized for being too slow,
    especially under Valgrind.  This commit is intended to accelerate it.  Tests are
    simplified in the following ways.
    
      1) Amount of data is reduced.  We're now close to the minimal amount of data,
         which produces at least one posting tree and at least two pages of entry
         tree.
      2) Three isolation tests are merged into one.
      3) Only one tuple is queried from posting tree.  So, locking of index is the
         same, but tuple locks are not propagated to relation lock.  Also, it is
         faster.
      4) Test cases itself are simplified.  Now each test case run just one INSERT
         and one SELECT involving GIN, which either conflict or not.
    
    Discussion: https://postgr.es/m/20181204000740.ok2q53nvkftwu43a%40alap3.anarazel.de
    Reported-by: Andres Freund
    Tested-by: Andrew Dunstan
    Author: Alexander Korotkov
    Backpatch-through: 11
    0c6f4f92
predicate-gin.spec 3.62 KB